A General Help Guide


Verified Member
So I see a lot of frequently asked questions, and while I've answered a few of them in time for the poster to see them, other people find a problem with the repack, then leave and are never seen again, thinking the problem was the repack itself, when it really wasn't (most of the time).

I'm making this "guide" to help anyone who has any questions about the repack that aren't specifically answered. Hopefully you've found this thread *before* pulling your hair out over a problem you just can't fix, and maybe this thread can help prevent this.

To start, I am no expert at any of this, so if I get something wrong, or if I'm unable to answer a question, I apologize. If I come across a problem that I do not know how to solve, I will look into it myself among various other WoW private server websites, or just plain extensive google searching. Also, I want to say that this guide isn't really for answering questions like "What is an IP" and whatnot, as I'd like to cover the harder questions first, however feel free to ask any question in this thread, and I'll try to answer it.
Helpful Links:

First, there are some links I figure you need to see before we continue, and they might answer your questions before they even need to be asked;
[OFFICIAL] A Guide for New Users by neccta has already made a very helpful guide for understanding some of the things you may see in a repack, such as mmaps, vmaps, MySQL, etc. You don't really need this information if you're just planning to set up your repack and go, but if you're looking to do anything beyond that, than this will help you get a good understanding of what you're looking at.

Making your server public
How to make server public with Hamachi -- Guide!
-both by our forum Admin, ExO. These will help you set up your repack public, so you can get your friends to play with you. There may be some future questions about this as sometimes, something goes wrong and it just wont work. Whatever happened, it's most likely a simple error like using the wrong IP, forgetting to put a period in said IP, etc. Remember, feel free to ask any question you may have that you feel hasn't been properly answered, or asked at all!

How to Fix 'Cannot Stream Required Archive Data'

How to fix 'Cannot connect to realm' error by Lingx
This thread is very helpful, as many people have had the problem of not being able to connect to their realm, yet they can log in. So far, most people who've had the problem was able to fix it using Lingx's solution.

Mouse Issue with 4.3.4 by Vazz
This isn't really a guide on fixing the issue, but more of a "where to look" to fix it. Vazz had a problem where his mouse would move all over the place in the World of Warcraft client, even though the mouse sensitivy wasn't the problem. Vazz's last post in the thread I linked to describes where he went to fix his problem.

TrinityCore Command List
This site is really great, as it provides all of the commands for TrinityCore, which I believe this repack uses.
To get ID's for objects, npcs, items, etc, use one of these commands:
.lookup creature $NPCName
.lookup item $ItemName
.lookup object $ObjectName
Note that some items, objects, and npcs can have multiple different ID's. You'll have to check through each one to see which one is what you want.
Now, in no particular order, I'm going to add any questions and answers that I see to this thread. Sorry if there isn't much organization, but in case this list gets a little too long (which it might not, depending if everyone is afraid to ask a question!), you could just use 'Ctrl+F' using your keyboard to search for whatever you're looking for.
Q: Character not being able to loot - relogging temporarily fixes but it always messes up again!
A: I have personally experienced this, and so far have seen 1 or 2 other people go through the same problem. While the cause may be different than yours, what caused mine was using the CharImporter (click here for the link to the CharImporter) for upgrading the server. I was using v5, then I donated and got v6, so I had to take my characters from v5 and import them to v6. All of my characters worked fine, but not my Shaman. I fixed this by simply going into my MySQL database (using HeidiSQL) and finding my character in the 'characters' table, copying the row (just right click the row and click copy) and deleting the current row. I then pasted the row back into the table. I know it sounds silly, but it actually worked! If that doesn't work for you, however, take a look at the 'guid' of the character, then delete the row. Then, go in game and re-create the character, use commands to level you up, and then go into the database and set your new character's GUID to the previous one. I believe this will match up the inventories and bank items, and maybe even spells.
Q:How can I update the repack? I don't want to lose my characters!
A:To update, use the CharImporter found here. It allows you to import characters from one server to another. I have personally used it to bring my characters from v4 to v5, then v6, and now v6.1, so I guarantee it works, at least for this repack. I prefer to use the template option, it seems safer and easier that way. As for a tutorial on how to use it, sadly I don't know if there is one. If you need help using it though, feel free to ask, and I'll help as best as I can!
Q: (For those who haven't used HeidiSQL or similar programs) I can't see all the rows in the database? All I see is a very limited amount of items, gameobjects, etc?
A: This is a simple question, but I've seen it once or twice and I felt it could get a quick answer. All you have to do is click the 'Show All' button in the top right corner of the data. It might take a second (or minute) to load, but it will then load every item in the table, then click 'entry' once to sort by the item entry id.
Q: Can't add a custom item into the database? It tells me a field item doesn't exist?
A: I'm assuming a lot of people still use wow-v for adding items into their server, and I'm not sure if they don't support trinity-core, or of this repack if slightly different from a normal trinity-core repack (or both). I've copied an insert from my database to build somewhat of a 'template' for adding items into this repack.
INSERT INTO `item_template` (`entry`, `class`, `subclass`, `SoundOverrideSubclass`, `name`, `displayid`, `Quality`, `Flags`, `FlagsExtra`, `Unk430_1`, `Unk430_2`, `BuyCount`, `BuyPrice`, `SellPrice`, `InventoryType`, `AllowableClass`, `AllowableRace`, `ItemLevel`, `RequiredLevel`, `RequiredSkill`, `RequiredSkillRank`, `requiredspell`, `requiredhonorrank`, `RequiredCityRank`, `RequiredReputationFaction`, `RequiredReputationRank`, `maxcount`, `stackable`, `ContainerSlots`, `stat_type1`, `stat_value1`, `stat_unk1_1`, `stat_unk2_1`, `stat_type2`, `stat_value2`, `stat_unk1_2`, `stat_unk2_2`, `stat_type3`, `stat_value3`, `stat_unk1_3`, `stat_unk2_3`, `stat_type4`, `stat_value4`, `stat_unk1_4`, `stat_unk2_4`, `stat_type5`, `stat_value5`, `stat_unk1_5`, `stat_unk2_5`, `stat_type6`, `stat_value6`, `stat_unk1_6`, `stat_unk2_6`, `stat_type7`, `stat_value7`, `stat_unk1_7`, `stat_unk2_7`, `stat_type8`, `stat_value8`, `stat_unk1_8`, `stat_unk2_8`, `stat_type9`, `stat_value9`, `stat_unk1_9`, `stat_unk2_9`, `stat_type10`, `stat_value10`, `stat_unk1_10`, `stat_unk2_10`, `ScalingStatDistribution`, `DamageType`, `delay`, `RangedModRange`, `spellid_1`, `spelltrigger_1`, `spellcharges_1`, `spellcooldown_1`, `spellcategory_1`, `spellcategorycooldown_1`, `spellid_2`, `spelltrigger_2`, `spellcharges_2`, `spellcooldown_2`, `spellcategory_2`, `spellcategorycooldown_2`, `spellid_3`, `spelltrigger_3`, `spellcharges_3`, `spellcooldown_3`, `spellcategory_3`, `spellcategorycooldown_3`, `spellid_4`, `spelltrigger_4`, `spellcharges_4`, `spellcooldown_4`, `spellcategory_4`, `spellcategorycooldown_4`, `spellid_5`, `spelltrigger_5`, `spellcharges_5`, `spellcooldown_5`, `spellcategory_5`, `spellcategorycooldown_5`, `bonding`, `description`, `PageText`, `LanguageID`, `PageMaterial`, `startquest`, `lockid`, `Material`, `sheath`, `RandomProperty`, `RandomSuffix`, `itemset`, `MaxDurability`, `area`, `Map`, `BagFamily`, `TotemCategory`, `socketColor_1`, `socketContent_1`, `socketColor_2`, `socketContent_2`, `socketColor_3`, `socketContent_3`, `socketBonus`, `GemProperties`, `ArmorDamageModifier`, `duration`, `ItemLimitCategory`, `HolidayId`, `StatScalingFactor`, `CurrencySubstitutionId`, `CurrencySubstitutionCount`, `flagsCustom`, `WDBVerified`) VALUES (ENTRY-ID, CLASS, SUBCLASS, -1, 'ITEM-NAME', DISPLAY-ID, QUALITY, 0, 8192, 1.0428, 1, 1, BUY-PRICE, SELL-PRICE, INVENTORY-TYPE, ALLOWED-CLASS, ALLOWED-RACE, ITEM-LEVEL, REQUIRED-LEVEL, 0, 0, 0, 0, 0, 0, 0, 0, 1, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 500, 0, 7, 0, 100, -1, 0, -1, 0, 0, 1000, -1, 0, -1, 0, 0, 0, -1, 0, -1, 0, 0, 0, -1, 0, -1, 0, 0, 0, -1, 0, -1, 1, '', 0, 0, 0, 0, 0, 6, 3, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 15595);
I'd suggest copying and pasting this code into notepad or something similar, and looking through and changing what needs to be changed. I replaced the values of the generally important fields with text, for example: For buy price, the item I used was originally 3, but I changed it to 'BUY-PRICE' for your convenience of editing. Remember, it counts as 'ggsscc' (g = gold, s = silver, c = copper). If you wanted to make it worth 100 gold 56 silver and 97 copper, you would set this to: 1005697
Q: What about Auction-House Bot (AHBot)? Does this repack have it? And how can I use it?
A: This repack (v5 and up) does, in fact, have AHBot implemented into it! To turn it on, or modify it, go into your worldserver.conf file and look for (Ctrl+F) 'AHBot' or 'Auction' or anything like that to see the settings. It can be a little confusing at first, and I wish I had a guide for it, but I do not fully understand it myself and I personally don't use it. If it's requested though, I'll try my best to find a proper tutorial on getting it to work. I would find one at the time of writing this, but it's a bit late at night, so I'm sorry about that. But of course, feel free to ask for how it works, and I'll try my best to answer! Or, if you'd like to know my alternate method to AHBot (it's not the best method, but it works), then just ask and I'll try to explain it.
Q: My worldserver.exe keeps crashing? I don't know what's wrong?
A: My guess is that you don't have your maps, vmaps, dbc, and mmaps folders, or at least not set up properly.
(SCREENSHOTS NEED TO BE UPDATED)Here is a screenshot of my main repack folder, here is a screenshot of my MySQL folder, and here is a screenshot of my Core folder. Notice, my Core folder might have some things you don't, and that's fine, as long as you have the maps, vmaps, mmaps, and dbc folders there, along with the authserver.exe/conf and worldserver.exe/conf, then you're golden.
A: While the above might work, sometimes it doesn't, and you need to know what the worldserver 'thinks' is the problem. So, to do this, try running the worldserver.exe as an admin, and it should help you find out the error. If not, there should be a way to enable a 'Crashes' folder, like you see in my Core folder, but that's either in the current VIP version, or I somehow enabled it and completely forgot. However, usually the problem is the first answer to this question, and even if it's all set up, the worldserver thinks it isn't. It could be a corrupted file, so try redownloading the maps, vmaps, mmaps, and dbs files, and if it still doesn't work, try redownloading the repack and see if that helps. If I find another fix for this, I will add it.
Q:How do I create an account/set my account as a GM?
A:This question is asked so often, that I can't believe I forgot to have it in here originally. I understand that some people don't like to use the default admin login, even if you're just hosting a server locally. I'm one of those people, myself, so I also wanted to know the command to create an account, and make myself a GM.
First, when your worldserver.exe is open, type this into it
.account create $Accountname $Password
Replace $Accountname with the name of your account, and $Password with the password you want to use to login.

Now, you have your own account, but you can't do any commands, and you're just a normal player. While some people may prefer this, so they wont be tempted to cheat, others may want to be a GM for a number of reasons. So here is the command for that; Just type this into the worldserver.exe file like the previous command:
.account set gmlevel $AccountName 3 -1
Replace $AccountName with your account that you want to be a GM. Explaining what the '3' and the '-1' mean isn't really necessary for the basics, so I wont go into detail about them. The '3' means the GM level, and the -1 means you are a GM on all realms. Replace it with the realm id if you have multiple realms if you only want someone to be a GM on that specific realm.
Q:How can I log into the database using HeidiSQL? What's the account info?
A:The information is:
Port: 3306
Username: root
Password: ascent
Q:I'm missing Ssleay32.dll and Libeay32.dll, what do I do?
A:Here is a link to the download:
Thanks to @
Q:Why doesn't my Worldserver.exe see my changes in worldconfig.cfg?
A:You can fix this by removing read-only mode in the folder's permissions.
Thanks to @
Q:How do I launch EmuCoach in Ubuntu?
A:Follow this tutorial here: https://www.emucoach.com/forums/threads/launching-emucoach-in-ubuntu.2062/
Thanks to @
Q: Character's items keep disappearing, then getting mail about items, or with different items?
A: Thanks to Mopower, this can be answered here: https://www.emucoach.com/forums/threads/character-items-missing.2162/
So far this is all I have at the top of my head, but I hope to add much more to this as I find questions/answers on my own, or by people asking me themselves.
Remember, if you don't see your problem here, don't be afraid to ask! Hopefully if I'm not currently available, or if I don't know the answer, someone more knowledgeable will answer you better than I could after only googling the problem.
Please delete my forum account, I no longer wish to be a part of the community.


MoP Premium