[OFFICIAL] A Guide for New Users

neccta

Veteran Member
35
2014
6
What is TrinityCore?

TrinityCore is a MMORPG Framework based mostly in C++.

It is derived from MaNGOS, the Massive Network Game Object Server, and is based on the code of that project with extensive changes over time to optimize, improve and cleanup the codebase at the same time as improving the in-game mechanics and functionality.

What is MySQL?

MySQL is a freely available open source Relational Database Management System (RDBMS) that uses Structured Query Language (SQL). SQL is the most popular language for adding, accessing and managing content in a database. It is most noted for its quick processing, proven reliability, ease and flexibility of use.

It is used to store creature spawn locations, item information, quests, and more.

What are Maps, VMaps, and DBCs?

Source
Maps: Maps are a must and TrinityCore does not run without them. The maps provide physical values and data for the core to interpret. Based on these, the core has a layout that can be compared with each client. This includes area definition.

DBCs: DBCs are a must and TrinityCore does not run without them. The DBCs ("Data Base Client [Files]") give essential values that the World of Warcraft client interprets. They define races, textures, local models and more. TrinityCore interprets these and loads them up.

VMaps: VMaps are optional, but highly recommended. VMaps ("Virtual Maps") calculate the possibility of line-of-sight, as an example. Based on their content, the server can (for example) calculate if spell casts are possible (e.g. if a wall is in between the target and caster or not).

MMaps: As of 02/2013, MMaps are experimental and thus optional. To further physical boundaries, MMaps ("Movement Maps") enforce physical boundaries on non-player, e.g. npcs, as their collision is not handled by the client. They also improve path generation.

What versions does TrinityCore support?
The most stable version TrinityCore supports is 3.3.3a(Wotlk) and currently has 6.0.3(WoD) in development, which is very unstable.

Does TrinityCore work on Linux or OSX?

TrinityCore will work on Linux and OSX, to learn more see http://collab.kpsn.org/display/tc/Requirements

What is open source?
Software for which the original source code is made freely available and may be redistributed and modified.

Where can I find TrinityCore open source files?

https://github.com/TrinityCore/TrinityCore/
 
Last edited:

neccta

Veteran Member
35
2014
6
MySQL says it's already running but I've never started it.

This is caused because of folder and file permissions, if your server is located in Program files it is recommend that you move them to your documents. If not right click on your _server folder, properties, security tab. Set the user to full control.
 
Last edited:

Crunchy28

Trial Member
1
2015
0
how can i setup heidisql? ihave no idea what mysql.bat password. it always says that "access denied for user 'root'@'localhost' (using password: YES)"
 

ExO

Admin
5,097
2014
1,469
how can i setup heidisql? ihave no idea what mysql.bat password. it always says that "access denied for user 'root'@'localhost' (using password: YES)"

Depends what MySQL provider you use, try root and password blank, OR root and ascent as password.
You can check this in the mysql config file.
 

zyrus23

Trial Member
3
2016
0
Location
Cuba
Help

Plase.... where i found your v6.1 or v6.0 4.3.4 repack??... i want to play whit my friends via LAN but the V5 had a lot of bugs in the starting areas and the paladins's templar veredict is buged.... plase i need help becouse i dont find the link of the v6 repack
PD: sorry about my english i from cuba
thanks
 

Mr. Satan

Admiral Squatbar
Mythical User
Head Moderator
Gold Supporter
MoP Premium
Superior Member
1,013
2016
177
Location
World Martial Arts Championships
Plase.... where i found your v6.1 or v6.0 4.3.4 repack??... i want to play whit my friends via LAN but the V5 had a lot of bugs in the starting areas and the paladins's templar veredict is buged.... plase i need help becouse i dont find the link of the v6 repack
PD: sorry about my english i from cuba
thanks

I'll try to explain this as simple as I can to help with translation. Sorry if it is not readable for you:

Version 6 and 6.1 are currently VIP only.
Version 5 is the current free version.
Version 6 might come out soon to public.

To get version 6.1, or the new version coming out, 6.2, you must donate to get VIP access.
$14.95 for one year VIP access, or $21.95 for life time VIP access.

You can go here to donate:
http://www.emucoach.com/payments.php
 

yilank

Silver Supporter
Veteran Member
42
2016
2
Location
London
Hi. When I tried to start "MySQL" in _Server Folder Cmd.exe said >>> MySQL could not be started. ?

What should I do. ( i did permission to folders administrator ). Should I setup first MySQL program. or should I start Your Folder inside have already MySQL application ?

Thx.

View attachment MySQL.jpg

View attachment MySQL 2.jpg

Edit; I worked to server, and i try to learn how can i change data base. Thx for noone helped. ( without #Brian8544, he was very helpfull, thx brian)
 
Last edited:

Aescleal

Gold Supporter
Veteran Member
126
2017
15
Hi, sorry I have some stupid questions I can't find answers to. (newb here)
First, I only have Version 1 of the Repack because it's the only one I could find.
Next, WorldServer won't start, and it closes before I can read why.
I'm starting (in order) Apache, then MySQL, then Authserver... and these all run fine I think... and lastly I start Worldserver. But as I said, it crashes. Is this a Version 1 issue? Or is it that I don't have my folders in the right places? Something is preventing it from starting up.
Since this sounds like an awesome server to run, I'm really excited to run it on my home LAN.
Are these stupid newb questions or what? :) Can somebody help me get up and running?
Thanks

Edit: Oh sorry, I'm trying to get the Cat server running, 4.3.4 Cat, v.1. I'd prefer v.5
 
Last edited:

Mr. Satan

Admiral Squatbar
Mythical User
Head Moderator
Gold Supporter
MoP Premium
Superior Member
1,013
2016
177
Location
World Martial Arts Championships
Hi, sorry I have some stupid questions I can't find answers to. (newb here)
First, I only have Version 1 of the Repack because it's the only one I could find.
Next, WorldServer won't start, and it closes before I can read why.
I'm starting (in order) Apache, then MySQL, then Authserver... and these all run fine I think... and lastly I start Worldserver. But as I said, it crashes. Is this a Version 1 issue? Or is it that I don't have my folders in the right places? Something is preventing it from starting up.
Since this sounds like an awesome server to run, I'm really excited to run it on my home LAN.
Are these stupid newb questions or what? :) Can somebody help me get up and running?
Thanks

Edit: Oh sorry, I'm trying to get the Cat server running, 4.3.4 Cat, v.1. I'd prefer v.5

When you say version 1, or 5, do you mean the first actual release of the cata repack?
The current public release version is v6.
You can download it here:
https://www.emucoach.com/showthread...hwings-Madness-v-5-EmuCoach-s-Official-Repack
 

Aescleal

Gold Supporter
Veteran Member
126
2017
15
When you say version 1, or 5, do you mean the first actual release of the cata repack?
The current public release version is v6.
You can download it here:
https://www.emucoach.com/showthread...hwings-Madness-v-5-EmuCoach-s-Official-Repack

Yes. v1 of the cata repack. I didn't realize I had to post in that forum before I could see the latest repack download links. I'll get those now and cross my fingers. However, is there a correct folder order I need to abide? Where do I place the vmaps and dbc, etc. folders?

EDIT: Got it. :) It loads up. Will playtest later when I'm not remote into my system.

Thanks for the help!
 
Last edited:

boggtroll

Trial Member
8
2015
1
Is there a step-by-step (click by click) tutorial on how to get a repack running? I used to run a 3.3.5a, 4.3.4, and a 1.12 server for myself...but that's been a few years ago and I can't remember what I did to get them working or where I got the information from. I'm trying to get the current paid version of 4.3.4 running (v13.1 i think). neither the worldserver nor authserver wants to start. I just get "The application was unable to start correctly (0xc000007b)." I made sure I have the required software installed along with any .dll I was missing before. Maybe that the paid versions folders could need to be named something different than _Server or Release? (I only think that from poking around the .conf files for world/auth.) Any help would be appreciated.
 
Last edited:

smity_wa

Trial Member
9
2021
0
Is there a step-by-step (click by click) tutorial on how to get a repack running? I used to run a 3.3.5a, 4.3.4, and a 1.12 server for myself...but that's been a few years ago and I can't remember what I did to get them working or where I got the information from. I'm trying to get the current paid version of 4.3.4 running (v13.1 i think). neither the worldserver nor authserver wants to start. I just get "The application was unable to start correctly (0xc000007b)." I made sure I have the required software installed along with any .dll I was missing before. Maybe that the paid versions folders could need to be named something different than _Server or Release? (I only think that from poking around the .conf files for world/auth.) Any help would be appreciated.
I also need this answered. I followed the video, copy the files and still get the same error.
 

McNasty

Trial Member
9
2022
1
Is there a step-by-step (click by click) tutorial on how to get a repack running? I used to run a 3.3.5a, 4.3.4, and a 1.12 server for myself...but that's been a few years ago and I can't remember what I did to get them working or where I got the information from. I'm trying to get the current paid version of 4.3.4 running (v13.1 i think). neither the worldserver nor authserver wants to start. I just get "The application was unable to start correctly (0xc000007b)." I made sure I have the required software installed along with any .dll I was missing before. Maybe that the paid versions folders could need to be named something different than _Server or Release? (I only think that from poking around the .conf files for world/auth.) Any help would be appreciated.
I also need this answered. I followed the video, copy the files and still get the same error.
Have you ensured you're using the correct OpenSSL? the version they require is dependent on the version used when they were compiled (I'm not sure which version the 4.3.4 uses here )
If you have used Libeay32.dll and ssleay32.dll from the openssl_32 and it doesnt run, try it from the openssl_64. 64 fixed it for me with the MoPVIP


Edit: I just realised they asked in 2021. apologies.
 

XeclipseX

MoP Premium
8
2024
2
MySQL says it's already running but I've never started it.

This is caused because of folder and file permissions, if your server is located in Program files it is recommend that you move them to your documents. If not right click on your _server folder, properties, security tab. Set the user to full control.
I have this issue, and once it loads it says

MySQL is currently running. Please only close this window for shutdown.
Please disregard any InoDB messages that are prompted. They have no use.
After your server is shut off, press CTRL C to shut down this service.
240307 12:09:09 [Note] Plugin 'FEDERATED' is disabled.
240307 12:09:09 InnoDB: The InnoDB memory heap is disabled
240307 12:09:09 InnoDB: Mutexes and rw_locks use Windows interlocked functions
240307 12:09:09 InnoDB: Compressed tables use zlib 1.2.3
240307 12:09:09 InnoDB: Initializing buffer pool, size = 128.0M
240307 12:09:09 InnoDB: Completed initialization of buffer pool
240307 12:09:09 InnoDB: highest supported file format is Barracuda.
240307 12:09:09 InnoDB: Operating system error number 87 in a file operation.
InnoDB: Some operating system error numbers are described at
InnoDB: http://dev.mysql.com/doc/refman/5.5/en/operating-system-error-codes.html
InnoDB: File name .\ib_logfile0
InnoDB: File operation call: 'aio read'.
InnoDB: Cannot continue operation.

MySQL could not be started.
Press any key to continue . . .

Any ideas?
 
Top