What's new

5.4.8 Battle Pay Shop

mj7911

MoP Premium
Verified Member
16
2022
2
Hi.
I'm a beginner.
I installed the sql file you uploaded as Navicat for MySQL.
However, I can't access Battle Payshop.
I don't know how to fix it.
Please tell me how to fix it.
이미지 5.jpg
이미지 4.jpg
 

mj7911

MoP Premium
Verified Member
16
2022
2
You have to enable it via your worldserver.conf :)
Thanks for the reply.
But I think I've solved only the first step of the solution.
When I connect to Battle Pay Shop, World Server and WoW are closed.
Please let me know if there is any other solution.
 

Attachments

  • 이미지 7.jpg
    이미지 7.jpg
    159.7 KB · Views: 274
  • 이미지 6.jpg
    이미지 6.jpg
    273 KB · Views: 272

Pythaeus

Gold Supporter
Veteran Member
31
2021
3
Same for me, after import this sql, server crash when open the shop.
any fixes ?
 

ClickedTech5

Gold Supporter
Verified Member
15
2021
3
Is there anyway to change where it says it will be charged to? I'm just wanting to edit the wording So far haven't found that setting anywhere

1666609551340.png


Has anyone found a way to have the shop charge gold instead of the default listed currencies?
 

LongCat

Veteran Member
48
2020
15
Going to try both versions of this shop. The one with the Gold, and the one without. Will report back. I really want to see this working. Perhaps it should be added to a future update as part of the server.

EDIT / UPDATE:

It works. I used the NO GOLD version that was in this post. Glad to finally have access to these items. Ty again.
 
Last edited:

michell87

Gold Supporter
Veteran Member
70
2015
11
Location
Brazil
maybe you can help me,i hope :D


1 FIRST
then load the Database to MOP_WORLD.

DOWNLOAD


2 SECOND
Need to change your WORLDSERVER.CONF

###################################################################################################
# BATTLE PAY SETTINGS
#
# BattlePay.StoreEnabled
# Description: Enable/Disable Battle Pay store
# Default: 0 - (Disabled)
# 1 - (Enabled)
#

BattlePay.StoreEnabled = 1

#
# BattlePay.Currency
# Description: Сurrency used for store
# Default: 0 - (None)
# 1 - (Dollar)
# 2 - (Pound)
# 3 - (Battle Coin)
# 4 - (Euro)
# 5 - (Ruble)
# 16 - (Test)
#

BattlePay.Currency = 16


3 THIRD
GO!
 
Last edited:

bumer1

Verified Member
24
2014
4
1 First
you need to download the ADDON below:

DOWNLOAD


2 Second
then load the Database to MOP_WORLD.

DOWNLOAD


3 Third
Need to change your WORLDSERVER.CONF

###################################################################################################
# BATTLE PAY SETTINGS
#
# BattlePay.StoreEnabled
# Description: Enable/Disable Battle Pay store
# Default: 0 - (Disabled)
# 1 - (Enabled)
#

BattlePay.StoreEnabled = 1

#
# BattlePay.Currency
# Description: Сurrency used for store
# Default: 0 - (None)
# 1 - (Dollar)
# 2 - (Pound)
# 3 - (Battle Coin)
# 4 - (Euro)
# 5 - (Ruble)
# 16 - (Test)
#

BattlePay.Currency = 16
Thank you very much, but the addon link you linked is the sql file not the addon so you linked the sql twice, can you re link the right link for the addon pls?
 

Dread1313

MoP Premium
Veteran Member
44
2023
7
So i've done some digging, and a lot of the items in the battlepay store are not in the game as items, in other words - the only items listed in the item_template table was the crate (36 slot) and the 2 exp pots (300% one and 100% one). None of the other items like lil ragnaros, the perky pug, none of the mounts I could find so far, the thunderfury, none of them are callable items (with .additem) command in the game. I am still unable to even open the store due to the GlueXML error specified above. The version client I am running I believe is 5.4.8 (18414). This is the tauri client and I dont know if its because I am running a bad client or what.

I understand some of the battlepay items might not even exist as an actual item in the game, more of a flag like "player now owns this pet or mount" and isnt an "addable" item, but it feels like the sword would at least be callable or something. So I am unsure whats going on here.
 
Top