What's new

V11 Warlock Bugs

destined_cruz

Gold Supporter
Gold Supporter
Joined
Oct 14, 2019
Messages
5
Reaction score
1
I use a chinese client, so spell names and item names may not be accurate.

[Location, Faction, Race] General
[Name, Type] Warlock, Summon Felguard (SpellID 30146)
[Problem Description] The summoned felguard use a "trident-like" weapon, I believe it should use a "arcanite-reaper-like" weapon.
[How it should work] summoned warlock pet felguard should use a "arcanite-reaper" like weapon.
felguard-weapon-problem.jpg
Btw, I've check the database. In table "creature_equip_template", the value of itemEntry1 for entry 17252 (I believe this is the entry id for warlock felguard pet) is 22199, and in table "item_template" the name of entry 22199 is indeed "Monster - Axe, 2H Arcanite Reaper".

[Location, Faction, Race] General
[Name, Type] Warlock, Human
[Problem Description] After reaching level 10, you learn from warlock trainer the spell "control-demon" so you can have pet control bar and related pet spells. However, for human warlock, the spell "control-demon" in the spell book still shows as "not learned".
[How it should work] For human warlock, the spell "control-demon" should show as "learned" in the spell book after you actually learned it from trainer.

control-demon-spell-problem-1.jpg In warlock trainer ui, it shows i've learned this spell (80388), pet bar shows normally.
control-demon-spell-problem-2.jpg In spell book, the spell (93375) shows as not learned.
The bug was found on human warlock. I've tested on blood-elf warlock, the problem does not exist. Other races haven't been tested.
 

captstu42

Member
Member
Joined
Jan 30, 2020
Messages
9
Reaction score
0
I ran into this with a Blood Elf 'lock, but not with an undead. Doing an unlearn and then buying the spell from the trainer again (a couple times over) it fixed it.
 

tinblue

Gold Supporter
Gold Supporter
Supporter
Registered User
Member
Joined
Jan 1, 2021
Messages
19
Reaction score
12
Gender
Male
I can confirm that despite having learnt control pet from the Warlock trainer it doesn't show in my passive skills despite it seemingly working fine. I think this is a bug that needs looking at.


wefwfwerfewr.png
 
Last edited:

pkman

Gold Supporter
Gold Supporter
Member
Joined
Sep 15, 2015
Messages
24
Reaction score
2
I use a chinese client, so spell names and item names may not be accurate.

[Location, Faction, Race] General
[Name, Type] Warlock, Summon Felguard (SpellID 30146)
[Problem Description] The summoned felguard use a "trident-like" weapon, I believe it should use a "arcanite-reaper-like" weapon.
[How it should work] summoned warlock pet felguard should use a "arcanite-reaper" like weapon.
View attachment 932
Btw, I've check the database. In table "creature_equip_template", the value of itemEntry1 for entry 17252 (I believe this is the entry id for warlock felguard pet) is 22199, and in table "item_template" the name of entry 22199 is indeed "Monster - Axe, 2H Arcanite Reaper".

[Location, Faction, Race] General
[Name, Type] Warlock, Human
[Problem Description] After reaching level 10, you learn from warlock trainer the spell "control-demon" so you can have pet control bar and related pet spells. However, for human warlock, the spell "control-demon" in the spell book still shows as "not learned".
[How it should work] For human warlock, the spell "control-demon" should show as "learned" in the spell book after you actually learned it from trainer.

View attachment 933 In warlock trainer ui, it shows i've learned this spell (80388), pet bar shows normally.
View attachment 934 In spell book, the spell (93375) shows as not learned.
The bug was found on human warlock. I've tested on blood-elf warlock, the problem does not exist. Other races haven't been tested.
Could it be the display Id not showing the correct weapon?
 

ExO

Administrator
Staff Member
Admin
Mythical User
Joined
Mar 29, 2014
Messages
4,721
Reaction score
535
Fixed on V14 (the spellbook)
 

destined_cruz

Gold Supporter
Gold Supporter
Joined
Oct 14, 2019
Messages
5
Reaction score
1
hey, any update on the display bug? its a little bit annoying you know ...
back then, i think i've checked most part of the database (i know of), like creature and creature_template table, so on.
everything seemed all right, so maybe the problem is not in the database?
and i've tested with other client and locale (enGB, enUS), so definetly not client-side.
so, maybe dbc file? just wild guess ...

anyway thanks for the bugfix :)
 
Top