What's new

Making your server public

Likon69

Mythical User
Silver Supporter
Superior Member
1,348
2020
544
So I think there's an issue with my hosts file in windows. I've added the following line:

# localhost name resolution is handled within DNS itself.# 127.0.0.1 localhost# myexternalipaddress mydyndns

This doesnt work. I've gotten rid of the extra spaces too. I have a dynamic ip I'm using for my external ip and I have a dns name connected to it. All needed ports are forwarded.

I've also just tried:

# (my external ip address) (my dns name)

and

# 127.0.0.1 localhost
# (my external ip address) (my dns name)

I've also tried those two lines without the hashtag....are the hashtags needed?

Please help!
please make a report. Are you trying to get it published for your friends or many people?
 

rasman

Verified Member
17
2022
7
please make a report. Are you trying to get it published for your friends or many people?
Just for my one roommate to connect to and maybe one other person. I'm not trying to run a fully public server or anything. Incidentally I've forwarded ports 8085 and 3724. Should I forward any other ports?
 

Chiliwhomp

Trial Member
5
2022
1
Okay hoping I can get a bit of advice on this one.. so as far as I can tell I have followed all the steps required and if I have a client external to my network attempt to access it they seem to be fine however if I try to connect to the same server from a client internal to the network using either the local or external ip, or the noip address I get no response at all as it cannot route properly.

I have a WOTLK that is also trinitycore based but that particular build has both a 'localaddress' and 'address' field so I was able to put in both the local subnet address and external ip respectively which seemed to resolve this problem. However this build doesn't have that field leaving me wondering where to go. This isn't for a big server just my kids and a couple of their friends to mess around in but if anyone has any advice where I might be going wrong I would really appreciate it.
 

icee20

Trial Member
2
2024
0
ok, I went through 3 times now, and everything is right, but when I try to log in from my laptop, it recognizes my login, sees the realm but when I try to log into the realm, I get the logging into game server and then it disappears without letting me in. any ideas??
 
Top