What's new

One Authserver for Arzeroth and EmuCoach World

thunder187

Supporter
Supporter
Registered User
Joined
Jan 6, 2021
Messages
6
Reaction score
0
Gender
Male
Hey Guys,

I'Ve a question . Is it possible to run 2 worldserver via one auth server ?
worldserver one (3.3.5 azerothcore) worldserver two (emucoach 4.3.4)
Actually every realm have an own auth server , so i have to use two account create websites and two realmlists i wish to change this thing .

Thanks for youre help

And sorry for my terrible english , i'm a german guy =)

Have a nice day =)
 

Jenniy

Gold Supporter
Gold Supporter
Supporter
Veteran User
Joined
Jan 1, 2020
Messages
74
Reaction score
13
I have had success myself at getting this to work. More specifically, I have had (but am not currently running all of) cMangos 3.3.5, EmuCoach 4.3.4 v7, two EmuCoach 4.3.4 v12, an EmuCoach 4.3.4 v13.1(now all 4 converted to v13.1), another [unknown source] 4.3.4, and EmuCoach 5.4.8 all running through the same Authentication server.

While I am saying that it certainly is possible to do, it is most certainly not a supported configuration and will likely require quite a bit testing to figure out what works for you.

In my case, the only way I successfully got the all to run off the same auth server was to launch each auth server packaged with the different distros sequentially, all pointing to the same database. First launch the auth server for the AZcore 3.3.5 then, afterward, set up the one for EmuCoach 4.3.4 and point it to the same authentication database. I went a step farther and followed up with 5.4.8 as well. After some extensive testing (At the time of setup - predating the x64 release of v13.1) the only Auth server I got that could successfully handle all the various servers was the one included with EmuCoach's 5.4.8 repack.

Your results may (will) vary and I can't guarantee anything but I can say with certainty that it is possible with enough fenagling!
 

thunder187

Supporter
Supporter
Registered User
Joined
Jan 6, 2021
Messages
6
Reaction score
0
Gender
Male
Hi Guys ,

this thread can be closed i've found my own solution . I have make a backup from all my databases and there is a sql file to update 3.3.5 auth to 4.3.4 auth
the tables that were missing ive add by my self and all was finde . Now both authdatabases runs over 4.3.4 authserver.

Tanks
 
Top