MoP quests bug

Likon69

Mythical User
Silver Supporter
Superior Member
1,346
2020
535
Alliance, Humain, Elwynn Forest.

We can't see where to return the quests. on the large map
 

ravish123

Gold Supporter
Senior User
279
2015
78
Yeah no POI information in DB. Here's a fix for etched letter:

Code:
DELETE FROM `quest_poi` WHERE `questId`=26910 AND `id`=0;
INSERT INTO `quest_poi` (`questId`, `id`, `objIndex`, `mapid`, `WorldMapAreaId`, `FloorId`, `unk3`, `unk4`) VALUES (26910, 0, -1, 0, 864, 0, 0, 1);

DELETE FROM `quest_poi_points` WHERE `questId`=26910 AND `id`=0 AND `idx`=0;
INSERT INTO `quest_poi_points` (`questId`, `id`, `idx`, `x`, `y`) VALUES (26910, 0, 0, -8924, -149);

Make sure to close the client and delete cache to see changes

Might need sniffs for deepest cut. Also seems to be an issue with other class quests with no POI information
 
Last edited:

Likon69

Mythical User
Silver Supporter
Superior Member
1,346
2020
535
Yeah no POI information in DB. Here's a fix for it etched letter:

Code:
DELETE FROM `quest_poi` WHERE `questId`=26910 AND `id`=0;
INSERT INTO `quest_poi` (`questId`, `id`, `objIndex`, `mapid`, `WorldMapAreaId`, `FloorId`, `unk3`, `unk4`) VALUES (26910, 0, -1, 0, 864, 0, 0, 1);

DELETE FROM `quest_poi_points` WHERE `questId`=26910 AND `id`=0 AND `idx`=0;
INSERT INTO `quest_poi_points` (`questId`, `id`, `idx`, `x`, `y`) VALUES (26910, 0, 0, -8924, -149);

Make sure to close the client and delete cache to see changes

Might need sniffs for deepest cut. Also seems to be an issue with other class quests with no POI information
Thank you so much!
 
Top